Linode, Bash, Tutorials, Development

 

Since the lamp stack comes with PHP 7.0 an upgrade is required.

First the packages to the server:

sudo apt install ca-certificates apt-transport-https
wget -q https://packages.sury.org/php/apt.gpg -O- | sudo apt-key add -
echo "deb https://packages.sury.org/php/ stretch main" | sudo tee /etc/apt/sources.list.d/php.list

Next update any updates available

sudo apt update

Install PHP 7.3

sudo apt install php7.3

Install PHP Extensions

sudo apt install php7.3-cli php7.3-common php7.3-curl php7.3-mbstring php7.3-mysql php7.3-xml

Install MBString

sudo apt install php-mbstring

Activate it

sudo phpenmod mbstring

Next install zip and dom

sudo apt install php-zip
sudo apt install php7.3-xml

Enable PHP7.3

sudo a2enmod php7.3

To disable PHP7.0

sudo a2dismod php7.0

Restart Apache2

sudo systemctl restart apache2